环境要求

满足基本的环境要求才能运行框架,SW-X 框架对环境的要求十分简单,只需要满足运行 Swoole4.5+ 拓展的条件,并且 PHP 版本在 7.3 以上即可。

基础运行环境

  • 保证 PHP 版本大于等于 7.3
  • 保证 Swoole 拓展版本大于等于 4.5+
  • 需要 Redis 版本大于等于 4.0+
  • 需要 pcntl 拓展的任意版本